ivanovich23
Imagen de ivanovich23
Posts: 2
Joined: 2007-10-06

Cuando instale Ubuntu, me reconocio el grabador de cd-rw marca LG que tenía instalado como maestro secundario IDE, hace unos dias coloque otro disco duro ide como maestro secundario y el cd-rom lo pase a slave secundario, y ahora tengo el problema que ubuntu no me lo reconoce, he intentado con las sugerencias que se hacen en otros hilos pero nada ha funcionado, ahora me he hecho un lio y necesito esa unidad, el problema no es de hardware, pues la monte en otro equipo con win y funcionó, pero en este nada,

la distribucion de los discos ide que tengo es

primario maestro disco duro de 80 gigas con 4 particiones: una ntfs para windowsxp, la swap, una ex3 y una fat32

primario slave un disco duro de 20 gigas con fat32

secundario maestro disco duro de 40 gigas con fat 32

secundario slave cd-rw

la configuración actual del /etc/fstab

/etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda4
UUID=ab18c08a-980d-411c-9ee2-60e51293bf0b / ext3 defaults,erro$
# /dev/sda1
UUID=E2ECBD1FECBCEEC3 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=4$
# /dev/sda5
UUID=4622-3967 /media/sda5 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sdb1
UUID=84485AEB485ADC0C /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=4$
# /dev/sda3
UUID=ce06ab45-2aac-4ccf-aa93-dc16a168d211 none swap sw $
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0

la ultima linea aparece así por que la edite siguiendo un hilo, pero no se si corresponda realmente a la ubicación del cdrom en mi equipo (slave-secundario) ya que cuando utilizo el comando sudo mount /media/cdrom0 el resultado que me da es: mount: el dispositivo especial /dev/hdd no existe

Asi mismo desde que dejo de reconocer el cd-rw, (al pasarlo de master a slave) e instale el disco duro secundario, es que los dos discos duros con fat32 los reconoce pero no los monta, toca hacerlo de manera manual, para mi eso no sería un problema, pero comparto el equipo con personas más novatas en ubuntu (mis hijas) y el no poder acceder a los discos y al cd-rw, les hace rechinar los dientes y lanzar comentarios sarcasticos del tipo ¿y no que ubuntu es mejor que w....?

la colaboración que pido es que me indiquen que archivos y/o carpetas debo borrar o editar para que desaparezca cualquier referencia al cd-rom y reiniciar para ver si ubuntu lo reconoce y monta automáticamente como cuando hice la instalación.

el sistema utiliza combinaciones de letras por ej hdc, sda, con que comando puedo saber que combinación asigna a cada disco?

que comando debo usar para que el sistema reconozca y monte los discos duros con fat 32 automáticamente?

o será que para solucionar los problemas debo reinstalar el sistema?



Jorolo
Imagen de Jorolo
Posts: 27
Joined: 2007-10-11
Raro

Hola ivanovich23.

Sobre el cd-rw

Hasta donde yo sé, algo así no debería pasar, aunque cambies la unidad de sitio debería detectarla allí donde esté.

La primera explicación que se me ocurre es: cuando pasaste la grabadora de master a esclava, además de cambiar la conexión del cable de datos ¿Cambiastes de posición el interruptor de los jumpers?

Sobre la nomenclatura de los dispositivos.
Recientemente este tema ha cambiado por lo que la mayoría de los manuales que hay en internet no te serán útiles. Yo tampoco sé muy bien como va el tema (uso una versión antigua de ubuntu con la nomenclatura clásica). Salta a la vista que tu usas una versión de ubuntu reciente (no dices cual) que usa la nomenclatura nueva.

los dispositivos IDE,antes dev/hdx, en tu caso aparecen como dev/sdx
por lo tanto deduzco:
IDE1 master = dev/sda
IDE1 slave = dev/sdb
IDE2 master = dev/sdc
IDE2 slave = dev/sdd (ese sería tu cd-rw)

Sobre los discos con fat32

Aquí veo dos problemas

En tu fstab solo aparecen las particiones de dos dispositivos (sda y sdb)
sdc no se monta porque no está listado en el fstab
sobre sdb, la información que aportas no cuadra, dices que es fat32 pero en el fstab está configurado como ntfs... no sé que pensar.

¿podrías mostrarnos la salida del comando: sudo fdisk -l?



ivanovich23
Imagen de ivanovich23
Posts: 2
Joined: 2007-10-06
salida del comando sudo fdisk l

e-desktop:~$ sudo fdisk -l

Disco /dev/sda: 80.0 GB, 80000000000 bytes
255 cabezas, 63 sectores/pista, 9726 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   *        4065        9726    45479983+   7  HPFS/NTFS
/dev/sda2               2        2236    17952637+   f  W95 Ext'd (LBA)
/dev/sda3            2237        2367     1052257+  82  Linux swap / Solaris
/dev/sda4            2368        4064    13631152+  83  Linux
/dev/sda5               2        2236    17952606    b  W95 FAT32

Las entradas de la tabla de particiones no están en el orden del disco

Disco /dev/sdb: 20.4 GB, 20416757760 bytes
255 cabezas, 63 sectores/pista, 2482 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sdb1               1        2482    19936633+   c  W95 FAT32 (LBA)

Disco /dev/sdc: 1031 MB, 1031798272 bytes
255 cabezas, 63 sectores/pista, 125 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sdc1   *           1         126     1007584    6  FAT16
La partición 1 tiene distintos finales físicos/lógicos:
     físicos=(124, 254, 63) lógicos=(125, 112, 50)

Disco /dev/sdd: 41.1 GB, 41110142976 bytes
255 cabezas, 63 sectores/pista, 4998 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sdd1   *           1        4997    40138371    c  W95 FAT32 (LBA)



Jorolo
Imagen de Jorolo
Posts: 27
Joined: 2007-10-11
Hola de nuevo. El fdisk ha

Hola de nuevo.

El fdisk ha dado un resultado sorprendente.

El disco fantasma
Disco /dev/sdc: 1031 MB

No has mencionado tener un disco duro de un giga, y dudo mucho que tengas semejante pieza arqueológica sin saberlo :)

¿Qué puede ser? Además de los discos duros ¿Tienes algún otro dispositivo de memoria? ¿una targeta de memoria? ¿un pendrive?

Con todo, no entiendo porque aparece intercalada entre los discos IDE. hay algo que no va bien, de hecho el formato de ese dispositivo es erroneo, cuando el fdisk dice "La partición 1 tiene distintos finales físicos/lógicos" debes preocuparte.

Sobre la partición del disco de 20GB
El fdisk dice:
/dev/sdb1 1 2482 19936633+ c W95 FAT32 (LBA)
Y el fstab dice:
UUID=84485AEB485ADC0C /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=4$

el fstab está mal, donde pone "ntfs" debería poner "vfat"

Sobre la partición del disco de 40GB
El fdisk dice:
/dev/sdd1 * 1 4997 40138371 c W95 FAT32 (LBA)
(debería ser sdc1 pero el disco fantasma lo ha despalzado)

Tienes que añadir en el fstab una línea como:
/dev/sdd1 /media/elnombrequequieras vfat defaults,utf8,umask=007,gid=46 0 1

(Para que funcione tendrás que crear el directorio /media/elnombrequequieras ) No trabajo con particiones de windows, si cometo algún error que me corrijan.